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Chapter 1 WinCE Overview

• Version： Wince6.0
• Source code:

◦ stepldr, EBOOT Souce code, support usb download.
◦ Wince 6.0 BSP

• Drivers in CD.
◦ RTC driver
◦ BINFS file system support
◦ Hive register support
◦ 256MB memory manager
◦ 4 serial ports driver
◦ network card driver.
◦ Audio driver
◦ LCD/touchscreen driver
◦ Camera driver
◦ TV-OUT driver
◦ Power manager, SLEEP driver
◦ SD card driver
◦ USB HOST driver
◦ USB OTG driver
◦ Keypad/LED driver
◦ WIFI driver
◦ GPS driver
◦ GPRS driver

• System characteristic
◦ Windows Media Player 9.0 ( supports MP3, MPEG2,

MPEG4, WMV, WAV and so on ).
◦ - Picture explorer, wordpad.
◦ - IE6 explorer.
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Chapter 2 Install VS2005 and WinCE 6.0

Whether VS2005 and WinCE6.0 proper installed is very important to the product
development. So when install the development environment please kindly follow our
user manual, step by step.
Real6410 development board support WinCE6.0 version, please refer to CDROM\
User manual\ VS2005_WINCE6.0 installation guidance.
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Chapter 3 Install the BSP

Real6410 development board WinCE6.0 BSP include two part: S3C6410_SEC_V1
and SMDK6410
1. Copy WinCE6.0\BSP\SMDK6410 to D:\WINCE600\PLATFROM\
2. Copy WinCE6.0\BSP\S3C6410_SEC_V1 to

D:\WINCE600\PLATFORM\COMMON\SRC\SOC
3. Remove S3C6410_SEC_V1 and SMDK6410 read-only properties.
4. Please confirm SMDK6410, S3C6410_SEC_V1 file has been copy to correct
directory
-->>SMDK6410
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-->>S3C6410_SEC_V1
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Chapter 4 Customize the BSP

4.1 Compiling the example projects in CD-ROM

Step 1. Find the “6410V2” project folder under the directory “WinCE6.0\project” in
CD-ROM. Copy this folder to the directory “D:\WINCE600\OSDesigns” and remove
the read-only property ( if there is no OSDesigns directory, you can create one. ).

Step 2.Run “VS2005”, select “File->open->Project/solution” In the VS2005 menu, then load
the file “D:\WINCE600\OSDesigns\6410V2\6410V2.sln” :

Step 3. Select Menu “Build”-> “Advanced Build Commands”->”Build and systen”
( If this is the first time to create project, we suggest you to select “Build”->
“Advanced Build Commands” -> “ Clean Sysgen”)

Step 4. After compiling, NK.bin has been generated under project directory:
"D:\WINCE600\OSDesigns\6410V2\6410V2\RelDir\Samsung_SMDK6410_Release".
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4.2 make user project files

The following contents introduce how to customize the user project files:

1. Open VS2005
2. Create new project, Select “File” -> “New” -> “Project”

• “Project Types” select “ Platform Builder for CE 6.0”
• “Template” select “OS Design”
• “Name:” input Project name “REAL6410V1”
• “Location: “ Set default name “ D:\WICNE600\OSDesigns”
• “Solution Name:” input solution name “REAL6410V1”
• Click “OK”
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3. Click Next
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4. Select project BSP
• “Available BSPs:” select “SMDK6410: ARMV41”
• Click “Next”
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5. Select project template
• “ Available design templates:“ Select “ PDA Device”
• Click “ Next”
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6. Select template type
• “Variants:” Select “Mobile Handheld”
• Click “Next”
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7. Add the application which is requirement by the user, below is the default
application

• "ActiveSync"
• “Internet Explorer 6.0”
• “Windows Media Audio/MP3”
• “Windows Messenger”
• “WordPad”
• Click “Next”
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8. Add network application
• Customer can defaults
• Click “Next”
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9. Click “ Finish”
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4.3 WinCE6.0 customization

1. Set target kernel type
• Select “SMDK6410 ARMV4I Release”
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2. Set project properties
• Select menu “Project” -> “Properties”

• "General” setting in Properties, default is ok, not change it.
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• “Locale” setting set the system language here.
◦ “Clear All” then select system language
◦ Click “English (American)
◦ Click “Chinese” (Chinese)
◦ Default locale: select “English (American)”

• “Build Options” setting
◦ Select option according to below picture. Click “Apply” and ”OK” to

return the VS2005.
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3. Add User Application-End
• Open “ Catalog Items View” Windows

• Add user application as follow:
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4. Add base class library for Application&ServiceS Development
You can choose it by needs
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5. Net Component Selection
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6. Select the operating system core service components
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7. File System Component Selection
• based on RAM and ROM file system
• HIVE-based registry of its in ROM, power-down is not lost
• supported BINFS, CD / UDFS File System, ExFAT, FAT file system

8. English font selection system, default it ok.
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9. Add multimedia components
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10. Font support non-English speaking countries
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11. Select Internet Services
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12. Shell and User Interface options
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13. General-purpose-driven selection

14. In VS2005 menu, Select Menu “Build”-> “Advanced Build Commands”->”Build
and systen”
( If this is the first time to create project, we suggest you to select “Build”->
“Advanced Build Commands” -> “ Clean Sysgen”)

After compiling, NK.bin has been generated under project directory:
"D:\WINCE600\OSDesigns\6410V2\6410V2\RelDir\Samsung_SMDK6410_Release".
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Chapter 5 Burning the Image to Flash

5.1 File introduce

IROM_SD_EBoot.nb0 : The tools to create SD boot card
Block0.nb0 ： Firstly Bootloader
eboot.bin ： Secondly Bootloader, booting NK
NK.bin ： WinCE Image file

5.2 Create SD boot card

(1) Insert the SD card to USB reader under WinXP, and format the SD card to
FAT32 format.
(2) Run the IROM_Fusing_Tool.exe tools,
the tools position:\tools\SDboot\IROM_Fusing_Tool.exe

3) burn bootloader
• Click “Browse”, add the file IROM_SD_EBOOT.nb0,

The file position: \tools\SDboot\IROM_SD_EBOOT.nb0
• select SD card in SD/MMC Drive under tools.
• Click “START”
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After burning the image successfully, there will be a pop-up windows “Fusing image
done”, Click “Ok” to finish creating the SD card.

4) Copy file
• Copy block0.nb0 to SD card root folder
• Copy eboot.bin and NK.bin to SD card root folder

The Image Position: CD:\WinCE6.0\Image

5.3 Burning the image into flash by SD card

1) Insert the SD card to the Real6410.
2) Set the board for SD boot mode

• set the digital switch to boot from SD mode as follow:
boot mode / Pin 1 2 3 4 5 6 7 8
SD card boot OFF OFF OFF OFF OFF OFF OFF OFF
Nand flash boot mode OFF ON OFF OFF OFF OFF OFF OFF

3) Connect the development board and PC via serial cable
4) Open the DNW software, and configure it(refer to the Appendix A DNW software
configuration)
5) Power on the board, then the DNW will print the message,
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6) Then within 3 second, press “Space” Key on PC keyboard, enter BOOT command
line.
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7) input A) B) C) to format the flash.
Please confirm the option 5), 6) is proper set as follow picture

8) Download block0.nb0
• Press “s” , it will show as that:
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• Press "0" to download block0.nb0 in to flash.

9) Download eboot.bin
• Reset the board, and press space key to enter the boot command again.
• press "s" -> "1" to download the eboot into flash

10) Download nk.bin
• Reset the board, and press space key to enter the boot command again.
• press "s" -> "2" to download the Nk.bin into flash

11) then set the board boot from Nand flash, and boot it, it will boot into the wince
system

• set the digital switch to boot from Nand boot mode as follow:
boot mode / Pin 1 2 3 4 5 6 7 8
SD card boot OFF OFF OFF OFF OFF OFF OFF OFF
Nand flash boot OFF ON OFF OFF OFF OFF OFF OFF

Note:The board can support the USB and Net update mode, if you need the
method, please contact us.

5.4 configure the LCD type for the board

The board can support more LCD type, you can choose it by boot command.
• Boot the board, and press space key to enter the boot command again,
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• Press “G” , it will show as that
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• Then choose the LCD type you used, such as press "1" to choose the
4.3"LCD.Then press "enter" and "W" to save the configure, reset the board
again, you will see the LCD is ok.

4.3"LCD ---- 1. WanXin WXCAT43
5"LCD------ --2. HannStar HSD050
7"LCD---------3.INNOLUX AT070V83V.1
VGA ----------4 VGA Moudle
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Chapter 6 Wince application program test

6.1 TouchScreen Calibration

Test Program positon: My Device-> control panel -> Stylus
Enter My Device-> control panel, and click Stylus to run the Stylus properties
tools, and click calibration to Recalibrate it.

6.2 ResidentFlash Flash use method

The board have two ResidentFlash, you can enter the MyDevice to use it, these size
is 31.7MB and 763.9MB.

6.3 use ActiveSync software

ActiveSync is a software to sysc the data between PC to the board.
1) install ActiveSync

• Click the ActiveSync software in the /tools/ActiveSync/ActiveSync.exe,
then click Next -Next to install it.

2) Connect the USB data cable with the development board and the PC, after power
on enters the system, WinCE will create synchronous connection automatically.
If you don't install the ActiveSync driver, you can find it in the folder: / tools/
ActiveSync/usb driver, When find the new device, install it.

3) Then you will find the My device in the computer
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Enter it, you will find that:

6.4 Record Function Test

There is tha MIC in the board, We can use it for Recording Test.
Test Program positon: My Device-> Windows -> Record.exe
This program was provide by Samsung, so we don't provide the program.
Double-click the Record.exe,

Then click follow button to begin Recording.

Then click follow button to stop Recording:

You can find the Record0.wav file in the program as follow:
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This file Record0.wav will be saved in the folder: My Device
Then we can click the follow button to play it:

6.5 Ethernet port test

Test Program positon: My Device-> control panel-> Network and Dial-up Co....

Doble click it, and it will show:
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The device "DM9CE1" is the net device, double cilck it and configure it as PC.
Then you can surf the net by IE explore.

6.6 WIFI test

The WIFI module is the option module, when you buy it, you can test it as follow:
When you boot the board, it will show the dialog automatic, then you can choose the
configure WIFI param, and input the password, it will link the net automatic by WIFI.

6.7 GPS module test

The GPS module is the option module, when you buy it, you can test it as follow:
Link the GPS antenna to GPS module, and put the antenna on the place that can
find the positioning signal.

Test Program positon: My Device-> Windows-> GPScmd.exe
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This test software is the third-party software, the company did not
source code

Click the GPScmd.exe, then it will show:

The GPS module was linked by COM3, and the baud rate is 9600， So choose it:

• Com Port: COM3
• Baudrate: 9600

And then click the cold start to run it, please wait some times, it will show:

6.7 Camera Test

This test software is the third-party software, the company did not
source code.
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And the software was base on the DirectDraw, you should add the
DirectDraw to project when you build the system.

Insert the Camera module into the board, note the Pin Order and the camera in the
board will face the LCD direction.

Test Program positon: My Device-> Windows-
>CameraDshowApp.exe
Run the CameraDshowApp.exe, and it will show :

Choose CAM1, and then click OK, it will show:
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6.7 GSM phone Test

6.7 TV-OUT Test

The board have two interface: S interface and AV interface, please link one to your
TV.

Test Program positon: My Device-> Windows->tvout_test_Swith.exe
Run the tvout_test_Swith.exe.

And it will show the system in TV, but note that it can't be exit from the TV display
except reboot the board.
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Chapter 7 WinCE Memory mapping table

7.1 Virtual memory mapping table

SMDK6410 virtual address to physical address mapping table as shown
below:

From this table, we can know the memory, net, other cs, IO mapping address, the
format for the table is :
virtual address physical address Size
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This table position:
X:\WINCE600\PLATFORM\SMDK6410\SRC\INC\oemaddrtab_cfg.inc

7.2 WINCE distributed memory
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Chapter 8 Export SDK and remote link

8.1 Export the SDK

When you finished to build the your project, you can export the SDK.
1) Click Menu “Project” à “Add New SDK…”

3) Select and inout the proper item according below picture
Click “OK”

4) On below project table there will be a MLCV3 generated

www.armdevs.com

Real6410 WinCE 6.0 Development manual



5) Compile the SDK
Click "build"-> "Build all SDKs...", Then wait a moment, i will create the
SDK in the position:

Notice: the MLCV3 is the project name.

www.armdevs.com

Real6410 WinCE 6.0 Development manual



8.2 VS2005 Remote to the board

We use the ActiveSync to link the board to the PC.
We need to create a folder "armv4" in the position:
" X:\Program Files\Common Files\Microsoft Shared\Windows CE
Tools\Platman\target\wce600"
And then copy all the content from armv4i to armv4.

Then Click the "Target-> Remote Tools -> Zoom" in the VS2005 menu, it will show
as follow:

Click "Cancel", then configure the link as AcitveSYNC mode, refer the follow pic:
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Then CLick "OK" to finished configure, click "Connection -> connect to Device".

Then it will shows as that:
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Appendix A DNW software configuration

1.Find DNW software under directory CD:\Tools\DNW.exe. Double-click to open it:

2. Click “Configuration -> Options”, it will open the “UART/USB Options” dialog.
• choose '115200' in 'Baud Rate'
• choose 'COM1' in 'COM Port '(the COM1 means the serial number in PC )

click 'OK' to finish the DNW configuration:

3.Then Click 'Serial Port->connect' to enable the DNW serial link.
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